STEC 60-2 electric trim suddenly stopped working TR182

Just thought I'd see if you had any ideas for me! I recently got my plane back from annual, and at about 0.7 hours of flying, the electric trim suddenly stopped working. As I recall, I had the AP engaged in ALT hold mode and turned the AP off by pushing the trim switch on descent. It never worked again.

Today I did some troubleshooting. The trim switch works to disengage the AP, but nothing it doesn't do anything else. I sprayed some contact cleaner in the switch, and it looks to be a pretty new switch in good condition. The cable to the trim servo is connected. As far as I could tell none of the wires going to/from the trim off/on switch were disconnected or damaged. Don't see how that could have happened spontaneously in level flight anyway..

I'm guessing the next step is to find the solenoid switch for the trim control, but I'm not sure where to find that. Of course I've contacted the A&P that just did the annual, but just thought I'd see if anyone had experienced something like this or had some ideas on where to go next with troubleshooting. Thanks!

Comments

  • Scott ShererScott Sherer COO Forum Moderator

    Hi Cole,
    I have a 55x and like you, I enjoy using my autopilot. Were I you, I would contact them. Here's the link: https://genesys-aerosystems.com/contact-us

    Scott Sherer
    Wright Brothers Master Pilot, FAA Commercial Pilot
    Aviation Director, Cessna Owners Organization Forum Moderator and Cessna Owners Author.

    Need help? Let me know!

Sign In or Register to comment.